2024-05-27 12:59 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005283WorldCup90[All Projects] Generalpublic2023-07-05 19:30
Reporterchristoph gleisberg 
Assigned ToStingRayProject InfoWorld Cup 90 (Genias)
http://www.whdload.de/games/WorldCup90.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Summary0005283: After starting the game I get an "access fault"
DescriptionGameVersion: english,pal,1 disk
SlaveVersion: 1.0 from 20.05.2000

After starting the game I get an "access fault"
TagsNo tags attached.
MachineA4000
CPU68040
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem16 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.5
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0010557

StingRay (developer)

Probably unsupported version, please send me your version or upload it somewhere, thanks.

note ~0012896

christoph gleisberg (reporter)

Sorry for the late reply, here is the image:

https://kabel-helpdesk.de/amiga_images/worldcup90.zip

note ~0012983

StingRay (developer)

Access fault was caused by byte write to volume register. Patch has been updated to fix this problem.

note ~0012989

christoph gleisberg (reporter)

Access fault seems to be fixed, thank you, but now I get the message "Exception illegal instruction" ($10) at $237CE (Tast 'Initial CLI' occurred".

note ~0012990

christoph gleisberg (reporter)

One more error :( see last message.

note ~0012994

StingRay (developer)

I can't reproduce this. Please try "NOCACHE" tooltype. If the error still occurs, please attach the .whdl_register file.

note ~0012996

christoph gleisberg (reporter)

nocache doesn't worked :(

here is the requested file:
https://www.kabel-helpdesk.de/amiga_images/.whdl_register

hope it helps you. The error appears at the genias logo at the start.

note ~0013000

Superman (reporter)

Confirmed same error for me on my A600 with furia and A1200 with TF1230. I get the logo with music then a crash.

note ~0013003

StingRay (developer)

Can you try attached slave please? I have changed the patch to use files instead of a disk image. To use the attached slave, you need to copy all files from the World Cup 90 disk to the "data" directory.

note ~0013005

christoph gleisberg (reporter)

Access fault - OK
Illegal instruction - OK

the only thing is that I can't navigate the pointer in the menus but I guess that's a problem of mine :)

Really thank you for your great help

note ~0013006

StingRay (developer)

Thanks for testing. The pointer can be controlled with joystick in port 2, make sure you don't touch the mouse though, then the pointer will behave weird for a while. :)
+Notes

-Issue History
Date Modified Username Field Change
2021-07-04 23:52 administrator New Issue
2021-07-04 23:52 administrator Status new => assigned
2021-07-04 23:52 administrator Assigned To => StingRay
2021-07-18 12:11 StingRay Note Added: 0010557
2023-06-12 13:30 christoph gleisberg Note Added: 0012896
2023-07-02 15:40 StingRay Note Added: 0012983
2023-07-02 15:40 StingRay Status assigned => resolved
2023-07-02 15:40 StingRay Resolution open => fixed
2023-07-03 06:15 christoph gleisberg Note Added: 0012989
2023-07-03 06:15 christoph gleisberg Status resolved => feedback
2023-07-03 06:15 christoph gleisberg Resolution fixed => reopened
2023-07-03 06:15 christoph gleisberg Note Added: 0012990
2023-07-03 15:43 StingRay Note Added: 0012994
2023-07-03 17:07 christoph gleisberg Note Added: 0012996
2023-07-03 17:07 christoph gleisberg Status feedback => assigned
2023-07-04 17:29 Superman Note Added: 0013000
2023-07-05 14:33 StingRay File Added: WorldCup90.slave
2023-07-05 14:35 StingRay Note Added: 0013003
2023-07-05 18:46 christoph gleisberg Note Added: 0013005
2023-07-05 19:06 StingRay Note Added: 0013006
2023-07-05 19:30 StingRay Status assigned => resolved
2023-07-05 19:30 StingRay Resolution reopened => fixed
+Issue History