2024-05-27 22:14 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0006299Altair_ZenerDrive[All Projects] Generalpublic2024-04-24 20:21
ReporterCCRider 
Assigned ToparajProject InfoZener Drive (Altair)
http://www.whdload.de/demos/Altair_ZenerDrive.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0006299: I encountered "Exception "Access Fault" ($4008) when running it. Tried the
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.0 from 20.05.2000

I encountered "Exception "Access Fault" ($4008) when running it. Tried the usual tool types, to no avail.
TagsNo tags attached.
MachineA1200
CPU68060
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem128 MB
WorkbenchOS 3.2
KickROM47 - Kick 3.2
KickSoftNone
WHDLoad18.9
importedyes
Attached Files
  • zip file icon ZenerDrive_20231120_test.zip (2,225 bytes) 2023-11-20 00:04
  • ? file icon .whdl_register (3,734 bytes) 2023-12-22 07:15 -
    ************************* 01-Jan-78 00:12:42 ************************18.9.6601***
    Slave='ZenerDrive.Slave' (2780 bytes)
    Resload    BD54440 -  BD5BEF8 (  31416) at BD54440  GL=$BDDCC00
    Slave      BDE4AB0 -  BDE5568 (   2744) at BDE4AB0  BaseMemSize=$80000
    ExpMem     BD5C000 -  BDDC000 ( 524288) at BD5C000
    attn=7() fc=-1 kn=25549 zpt=-1 ep=0 ei=0
    setcpu=0(SNCS,ENCS,BNCS)
    
    Exception "Line 1111 Emulator" ($2C) at $20042008 occurred.
    exception stackframe:
    $0BDDBFE8 20042004 2008002C
    regular stack:
    $0BDDBFF0 0BD56000 0BD56000 67FC6000 0BD56000
    
      ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
    Dx        0  FFF5FFA5         8   BDCBB49       801         0      1002   BD90279
    Ax   DFF006   BDB541C     54650   BDB5404   BDB7EAE   BDAB920   BDCBB48
    
                     TTSM III   XNZVC
    PC=2004200822m  SR=%0010000000000100  USP=BDCD638  1mISP=BDDBFE8  MSP=7F800
    VBR=BDDDC00  SFC=5  DFC=5  CACR=2000  CAAR=0  TT0=0  TT1=0
    TC=0  CRP=100000000  SRP=100000000  MMUSR=0
    
             MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
    intena=%011000000010000022m dmacon=%1m0010011111000000 adkcon=$1100
    intreq=%0000000001000000
    vposr....A300  vhposr...0274  joy0dat..0003  joy1dat..0000  clxdat...8023  
    pot0dat..6B52  pot1dat..5252  potinp...5500  serdatr..3800  dskbytr..A000  
    deniseid.00F8  hhposr...FF58  
       ciaa:     PI ROPS		   ciab:     PI ROPS
    	cra=0000000022m  ta=21FF<21FF	   cra=1m00000000  ta=FFFF<FFFF
    	    AII ROPS			    AII ROPS
    	crb=0000100022m  tb=C87E<FFFF	   crb=1m00001000  tb= 1F0< 1F0
    	    10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    	pra=1111111022m  prb=1m1111111122m      pra=1m1111111122m  prb=1m11111111
           ddra=0000001122m ddrb=1m0000000022m     ddra=1m1100000022m ddrb=1m11111111
           event=0000F9  icr=00  sdr=00    event=011BA9  icr=00  sdr=00
    
    ************************* 01-Jan-78 00:12:49 ************************18.9.6601***
    Slave='ZenerDrive.Slave' (2780 bytes)
    Resload    BD54440 -  BD5BEF8 (  31416) at BD54440  GL=$BDDCC00
    Slave      BDE4AB0 -  BDE5568 (   2744) at BDE4AB0  BaseMemSize=$80000
    ExpMem     BD5C000 -  BDDC000 ( 524288) at BD5C000
    attn=7() fc=-1 kn=25549 zpt=-1 ep=0 ei=0
    setcpu=0(SNCS,ENCS,BNCS)
    
    Exception "Line 1111 Emulator" ($2C) at $20042008 occurred.
    exception stackframe:
    $0BDDBFE8 20042004 2008002C
    regular stack:
    $0BDDBFF0 0BD56000 0BD56000 67FC6000 0BD56000
    
      ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
    Dx        0  FFF5FFA5         8   BDCBB49       801         0      1002   BD90279
    Ax   DFF006   BDB541C     54650   BDB5404   BDB7EAE   BDAB920   BDCBB48
    
                     TTSM III   XNZVC
    PC=2004200822m  SR=%0010000000000100  USP=BDCD638  1mISP=BDDBFE8  MSP=7F800
    VBR=BDDDC00  SFC=5  DFC=5  CACR=2000  CAAR=0  TT0=0  TT1=0
    TC=0  CRP=100000000  SRP=100000000  MMUSR=0
    
             MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
    intena=%011000000010000022m dmacon=%1m0010011111000000 adkcon=$1100
    intreq=%0000000001000000
    vposr....A300  vhposr...0274  joy0dat..0003  joy1dat..0000  clxdat...8023  
    pot0dat..6B52  pot1dat..5252  potinp...5500  serdatr..3800  dskbytr..A000  
    deniseid.00F8  hhposr...FF58  
       ciaa:     PI ROPS		   ciab:     PI ROPS
    	cra=0000000022m  ta=21FF<21FF	   cra=1m00000000  ta=FFFF<FFFF
    	    AII ROPS			    AII ROPS
    	crb=0000100022m  tb=C87E<FFFF	   crb=1m00001000  tb= 1F0< 1F0
    	    10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    	pra=1111111022m  prb=1m1111111122m      pra=1m1111111122m  prb=1m11111111
           ddra=0000001122m ddrb=1m0000000022m     ddra=1m1100000022m ddrb=1m11111111
           event=0000F9  icr=00  sdr=00    event=011BA9  icr=00  sdr=00
    
    ? file icon .whdl_register (3,734 bytes) 2023-12-22 07:15 +

-Relationships
+Relationships

-Notes

note ~0013318

paraj (developer)

Thanks for report, but please next time make a crash dump and include at least ".whdl_register" (.whdl_dump is even more useful, but is usually too large for mantis)

Does attacheed slave fix it?

note ~0013319

CCRider (reporter)

Sorry for not adding .whdl_register on the original report: This slave wasn't available on Mantis when I tried to report, so the WHDLoad site offered me a webform to report. Apparently, it was added to Mantis just after my report.
But now for good news: this newer slave worked first try!

note ~0013320

paraj (developer)

Great! No worries about the register file. Problem was apparently race condition with module player startup that only showed on KS3.2 + 060 (or well, maybe others). I was able to reproduce under emulation, but I didn't catch it because my 060 has KS3.1, and other testers with 3.2 had other setups.

I'll release an update once there's been a bit of time for other issues to show.

note ~0013444

Snoopy1234 (reporter)

Exception "Line 1111 Emulator" ($2C) at $20042008 occured.
whdl_register dump attached.

note ~0013445

Snoopy1234 (reporter)

0006299:0013444 is for slave 1.x on an A1200 ACA 030. whdl_register reports stack overflow. Slave 1.x ironically is the only slave that runs on a DKB 030.
Slave 0.2 speed 5 is correct for ACA 030.

note ~0013665

paraj (developer)

I think the reported issue should be fixed with recently release 1.1 slave. @Snoopy1234, does it still happen with 1.1? If yes does setting of "Disable slowdown" matter?.

note ~0013674

Snoopy1234 (reporter)

@paraj

Perfect. Disabled slowdown improves audio/gfx synchronization and full frame on the end part. ACA 030 40mhz A1200.

note ~0013683

paraj (developer)

Great. I'll close this issue then. Please open a new one if there are still issues.
+Notes

-Issue History
Date Modified Username Field Change
2023-11-18 18:19 administrator New Issue
2023-11-18 18:19 administrator Status new => assigned
2023-11-18 18:19 administrator Assigned To => paraj
2023-11-20 00:04 paraj File Added: ZenerDrive_20231120_test.zip
2023-11-20 00:04 paraj Note Added: 0013318
2023-11-20 00:29 CCRider Note Added: 0013319
2023-11-20 00:39 paraj Note Added: 0013320
2023-12-22 07:15 Snoopy1234 File Added: .whdl_register
2023-12-22 07:17 Snoopy1234 Note Added: 0013444
2023-12-22 09:07 Snoopy1234 Note Added: 0013445
2024-04-11 20:20 paraj Note Added: 0013665
2024-04-22 10:55 Snoopy1234 Note Added: 0013674
2024-04-24 20:21 paraj Note Added: 0013683
2024-04-24 20:21 paraj Status assigned => closed
2024-04-24 20:21 paraj Resolution open => fixed
+Issue History