2023-06-02 17:19 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003214KrustysSFH[All Projects] Generalpublic2015-07-13 22:39
Reporterretrogamer 
Assigned ToWeplProject InfoKrusty's Super Fun House (Virgin)
http://www.whdload.de/games/KrustysSFH.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0003214: Get an errormessage when running the game with a 68000 cpu. Expection "Adress
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.0 from 20.05.2000

Get an errormessage when running the game with a 68000 cpu.
Expection "Adress Error" (F00C)
PC=22F3B4 (Slave 1B4)
TagsNo tags attached.
MachineA600
CPU68000
CPUSpeed7
ChipSetECS
GFXCardNone
ChipMem2 MB
FastMem8 MB
WorkbenchOS 2.1
KickROM37 - Kick 2.0
KickSoftNone
WHDLoad18
importedyes
Attached Files
  • ? file icon .whdl_register (2,990 bytes) 2015-04-10 21:56 -
    ************************* 28-Jan-11 18:22:07 ************************18.0.5614***
    Slave='KrustysSuperFunHouse.Slave' (692 bytes)
    ShadowMem   3455C0 -   37A5C0 ( 217088) AbsolutMem    35000 -    80000 ( 307200)
    Resload     33AEE0 -   341564 (  26244) at 33AEE0  GL=$2D7BB0
    Slave       231220 -   2314B0 (    656) at 231220  BaseMemSize=$80000
    attn=200(UAE,00) fc=-1 kn=20421 cs=1851 rw=0 zpt=-1 ep=0 ei=0
    setcpu=33D(DC,IC,SCB,ECB,BNC)
    
    Exception "Address Error" ($F00C) PC = $2313D4 (Slave $1B4) Read from $1C801
    
    $00231398 bsr.b        $2313ce
    $0023139a movem.l      (a7)+,d0-d1/a0-a1              ;$0007ffde
    $0023139e bsr.w        $231438
    $002313a2 move.l       ($231482,pc),d0
    $002313a6 tst.l        d0
    $002313a8 beq.b        $2313ca
    $002313aa move.w       #$4e75,($21128)
    $002313b2 move.w       #$4e75,($210d8)
    $002313ba move.w       #$6004,($1f674)
    $002313c2 move.w       #$4e75,($2108c)
    $002313ca jmp          ($5000).w
    $002313ce cmpa.l       a0,a1
    $002313d0 beq.b        $2313de
    $002313d2 cmp.l        (a0),d0                        ;$0001c801
    1m$002313d4 beq.b        $2313da
    22m$002313d6 addq.l       #1,a0
    $002313d8 bra.b        $2313ce
    $002313da move.l       d1,(a0)                        ;$0001c801
    $002313dc bra.b        $2313ce
    $002313de rts
    $002313e0 move.w       d2,($58,a6)                    ;$00dff058
    $002313e4 bra.b        $2313f4
    $002313e6 move.w       #$f014,($58,a6)                ;$00dff058
    $002313ec bra.b        $2313f4
    $002313ee move.w       #$7314,($58,a6)                ;$00dff058
    $002313f4 tst.b        ($dff002)
    $002313fa tst.b        ($bfe001)
    $00231400 tst.b        ($bfe001)
    $00231406 btst         #6,($dff002)
    
    exception stackframe:
    $0007FFDE 00150001 C801B090 20000023 13D4
    regular stack:
    $0007FFEC 0023139A 00000000 000003DA 00004FE0 0007C844
    
      ----0---- ----1---- ----2---- ----3---- ----4---- ----5---- ----6---- ----7----
    Dx 3D420058  4EB80100       1BF         0  D4D4D4D4  D5D5D5D5  D6D6D6D6  D7D7D7D7
    Ax    1C801     1E000    33AEE0  A3A3A3A3  A4A4A4A4  A5A5A5A5    DFF000
    
                     TTSM III   XNZVC
    PC=  2313D422m  SR %0010000000000000  USP=7FC00  1mSSP=7FFDE
    
             MEDRAAAABVCPSDT          YZ  PMRCBSDAAAA
    intena=%000000000000000022m dmacon=%1m0010001010000000 adkcon=$1100
    intreq=%0010000000100000
    vposr....A000  vhposr...04CB  joy0dat..0202  joy1dat..0000  clxdat...81FE  
    pot0dat..7800  pot1dat..0000  potinp...5500  serdatr..3000  dskbytr..0000  
    deniseid.FFFC  hhposr...006C  
       ciaa:     PI ROPS		   ciab:     PI ROPS
    	cra=0000000022m  ta=21FF<21FF	   cra=1m00001000  ta= 2CC< 2CC
    	    AII ROPS			    AII ROPS
    	crb=0000000022m  tb=21FF<21FF	   crb=1m00000000  tb=FFFF<FFFF
    	    10RTWCLO	  parallel	    DRCCDSOY      M3210HDS
    	pra=1111110022m  prb=1m1111111122m      pra=1m0000011122m  prb=1m11111111
           ddra=0000001122m ddrb=1m0000000022m     ddra=1m1100000022m ddrb=1m11111111
           event=000113  icr=00  sdr=00    event=01503B  icr=85  sdr=00
    
    ? file icon .whdl_register (2,990 bytes) 2015-04-10 21:56 +
  • ? file icon KrustysSFH.Slave (728 bytes) 2015-04-11 11:31

-Relationships
+Relationships

-Notes

note ~0004508

Wepl (manager)

please make a dump and attach the .whdl_register file to this issue

note ~0004509

retrogamer (reporter)

Sure, I have uploaded the file now

note ~0004510

Wepl (manager)

Please try the attached Slave.

note ~0004512

retrogamer (reporter)

The new slave seems to work fine on 86000 cpu now even the quit option .

Will the new slave be published on the whdloadsite?

note ~0004513

Wepl (manager)

New install packages has been released.

note ~0004515

Retroplay (reporter)

New install fails to image SPS 1599.
I get a no sector header error while reading track 1.

In fact, it's only the imager in the old KrustySFH-19991025 archive which manages to image the SPS 1599 image.

note ~0004516

Wepl (manager)

Try the updated install package.

note ~0004517

Retroplay (reporter)

Thanks, it works now.

note ~0004558

CFOU (developer)

Last edited: 2015-05-06 14:38

View 2 revisions

it was stupid bug in slave file caused by me!!

sorry for that ;)

+Notes

-Issue History
Date Modified Username Field Change
2015-04-10 21:28 administrator New Issue
2015-04-10 21:28 administrator Status new => assigned
2015-04-10 21:28 administrator Assigned To => CFOU
2015-04-10 21:34 Wepl Note Added: 0004508
2015-04-10 21:34 Wepl Assigned To CFOU => Wepl
2015-04-10 21:56 retrogamer File Added: .whdl_register
2015-04-10 21:57 retrogamer Note Added: 0004509
2015-04-11 11:31 Wepl File Added: KrustysSFH.Slave
2015-04-11 11:32 Wepl Note Added: 0004510
2015-04-11 13:00 retrogamer Note Added: 0004512
2015-04-11 13:26 Wepl Note Added: 0004513
2015-04-11 13:26 Wepl Status assigned => resolved
2015-04-11 13:26 Wepl Resolution open => fixed
2015-04-11 16:13 Retroplay Note Added: 0004515
2015-04-11 17:07 Wepl Note Added: 0004516
2015-04-11 18:31 Retroplay Note Added: 0004517
2015-05-06 14:37 CFOU Note Added: 0004558
2015-05-06 14:38 CFOU Note Edited: 0004558 View Revisions
2015-07-13 22:39 Wepl Status resolved => closed
+Issue History