2024-05-19 07:23 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004906IndyFateOfAtlantis[All Projects] Generalpublic2020-12-12 22:39
ReporterLovrenco 
Assigned ToJOTDProject InfoIndiana Jones & The Fate of Atlantis (Lucasfilms Games)
http://www.whdload.de/games/IndyFateOfAtlantis.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0004906: Can someone tell me what does "Invalid size allocating string 31 size -1" error
DescriptionGameVersion: english,pal
SlaveVersion: 2.2 (21.02.17)

Can someone tell me what does "Invalid size allocating string 31 size -1"
error means and is there a way to fix it?
I get this in Indiana Jones and Fate of Atlantis game, when the save game disk is checked at beginning. I think Amiga hung up during the save procedure and the virtual disk got corrupted somehow. Any ideas?
TagsNo tags attached.
MachineA1200
CPU68020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem8 MB
WorkbenchOS 3.1
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.2
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0009333

JOTD (developer)

can you share your installation files somewhere?

note ~0009336

Lovrenco (reporter)

Here you go, full installation directory, copied from the amiga:

https://drive.google.com/file/d/187p6bFphUKhaqphDl5oPm4fh2G-xVEb2/view?usp=sharing

note ~0009337

Lovrenco (reporter)

Worth noting that it is packed on amiga using Dopus.

note ~0009338

Lovrenco (reporter)

I would be grateful if explanation is provided, what happened and is there a way that I can fix it in the future for this and any other game that crashes this way?

note ~0009339

JOTD (developer)

an update has been posted to whdload page. The problem was an empty iq-points file that confused the game.

But deleting it isn't a very good idea too. I suggest that you wait for the new .slave file to be published.
+Notes

-Issue History
Date Modified Username Field Change
2020-12-09 17:21 administrator New Issue
2020-12-09 17:21 administrator Status new => assigned
2020-12-09 17:21 administrator Assigned To => JOTD
2020-12-11 23:06 JOTD Note Added: 0009333
2020-12-11 23:06 JOTD Status assigned => feedback
2020-12-12 20:26 Lovrenco Note Added: 0009336
2020-12-12 20:26 Lovrenco Status feedback => assigned
2020-12-12 20:28 Lovrenco Note Added: 0009337
2020-12-12 22:30 JOTD Status assigned => closed
2020-12-12 22:30 JOTD Resolution open => fixed
2020-12-12 22:37 Lovrenco Status closed => feedback
2020-12-12 22:37 Lovrenco Resolution fixed => reopened
2020-12-12 22:37 Lovrenco Note Added: 0009338
2020-12-12 22:39 JOTD Note Added: 0009339
2020-12-12 22:39 JOTD Status feedback => closed
2020-12-12 22:39 JOTD Resolution reopened => fixed
2020-12-12 22:39 JOTD Description Updated View Revisions
+Issue History